Connect via USB stopped working, IP keeps resetting

1 people are following

Hi! I've had a zero w in my pc for over a year or so running over usb with no issues. a while ago I had to re-install windows and now the RPi cant find the modbros app anymore. 

I've re-installed the the same RNDIS driver from before but when I set the IP address to and gate to it gets reset to empty when leaving the settings. Not sure what is different from before, but I've tried it with an IP of and that saves fine so seems my pc has an issue with the IP address? 

I've tried connecting with the firewall in/out rules applied and also with the firewall completely off and both made no difference.

I don't know much about setting up IP so not a clue what could cause it and I've also tried the google solution of using flushdns in cmd. I've also tried connecting over wifi instead and this works fine but quite frequently loses connection hence wanting it back over usb, I've also connected fine with my phone and that also works with no issue.

Any advice or solutions would be greatly appreciated!

Replies 1 - 1 (1)

I have now managed to get the IP to stay, turns out I forgot to run as admin in cmd. After updating the fire wall settings the RPi is now working again.

For any one with the same issue, it is likely caused by windows already having the IP on the system and seeing it as a duplicate when you enter it. using this command in CMD “NETSH int ip reset log.txt" resets the addresses allowing you to use it again. Just make sure to run CMD as admin or it doesn't seem to work.

Login to comment

Login now
Like most websites, we also use cookies. But don't worry, we only use them for your login and statistics.