QUESTION

Custom fonts are not getting displayed on raspberry pi

4 people are following

Hello ModBros / Community,

 

first of all thanks to the Bros for providing this awesome Project!

I first found out about the MoBro Application late 2019 whe i was building my first gaming PC (was lucky cards were affordable back then xD)

Its awesome to see the progress of this project and how the community contributes here.

 

I have a question about the new customization system (v12_2 pi image, using Raspberry pi 3b+).

I would like to use custom fonts for my Status monitor design.

The MoBro Desktop Client lets me customize the layout and text fields, including font choice, but when i finish customizing the font displayed on the pi is still the default one.

Everything else works great.

 

I assume that i have to install the fonts locally to my pi so it works?

If so, to which path do i have to copy the font files.

Replies 1 - 6 (6)

I have tried around a bit and found out that the mobro pi image uses the default font directory /usr/share/fonts/

If you use one of the three preinstalled fonts from the pi image in the desktop app in customization, 
the changes also apply on the pi.

In the next step i tried to copy my custom fonts to 
/usr/share/fonts/truetype/*custom-font-folder-name* 
but sadly the files get deleted every time i reboot, no matter what im doing.

Already tried set_boot_configurable and set_root_configurable but it didnt help.

Does anyone have an idea? :)

Hi there!

In my case I’ve done that by disabling overlayFS and added a “.fonts” folder inside the modbros user folder. Add the fonts to that folder and run fc-cache to update the font cache.

Then activate the overlayFS again 👍

 

I GOT IT RUNNING!

What i was missing out was that you have to disable OverlayFS first so any file changes can apply.

Easiest way to disable OverlayFS ist to access your pi via IP Address in a Web Browser and use the graphical config setup. In one of the later steps there is an option to disable OverlayFS.

Then i copied my fonts as described earlier to 
/usr/share/fonts/truetype/*custom-font-folder-name* 

(Dont forget to set chown to root for the font files. Maybe not necessary, but it doesnt hurt ;) )

Then you can reboot the pi and voila:

Custom fonts are applied to your pi too.

IMPORTANT: After applying my changes i enabled OverlayFS back, dont forget.

 

Hope this will help someone out :)

Hey magnificent3,

sry i read your answer too late. Anyways thanks for your answer.

You are absolutely right, it was the OverlayFS.

Hi guys, hmm basically the app should be able to serve the fonts directly for the pi. I'll take a look if there is something wrong. @magnificent3 @Ravinmaq thanks for finding a workaround for that issue :)

Dave

Hi guys, hmm basically the app should be able to serve the fonts directly for the pi. I'll take a look if there is something wrong. @magnificent3 @Ravinmaq thanks for finding a workaround for that issue :)

Hi Dave, Thanks for all the work you guys put in for such an amazing program. Have you resolved this issue without having to add the fonts to the Rpi. I still see no changes to fonts on display itself but they do change on Modbros application. Looking forward to hear from you. Thanks!!

 

Login to comment

Login now
Like most websites, we also use cookies. But don't worry, we only use them for your login and statistics.