REPORT AN ISSUE

No HDMI-output or DSI to official 7" screen.

2 people are following

I can access the web-setup and do that, it boots and I can SSH to it, so I know it's booted up, but I get nothing from the HDMI port or using the official 7" touchscreen. I have tried both the “standard hdmi and dsi” and the “official touchscreen” options in the setup and neither work for either option. 

 

Any ideas?

 

Replies 1 - 7 (7)

Hi @paradox 

Which Raspberry Pi model are you using?

And how exactly are you connecting it via HDMI? 
As far as I'm aware the official 7" touchscreen only comes with a ribbon cable for the DSI port and doesn't have a HDMI port at all.

Alright an update. Firstly I meant the HDMI port on the RPi itself, just seeing if I could get any output - I can now on my PC monitor using it with Raspbian.

I managed to get HDMI-out working using Raspbian. Touchscreen won't work though with it.

It's an RPi 3B v1.2.

I have installed ModBro, SSHd into it and did set_root_configurable, then it restarted and now the windows application detects it:

af4ec8b7-3085-4e53-9e2c-412a4de95a85.png

However SSH has stopped working. Maybe the IP changed I'll see..

No it's the same:

fc7f7a49-f566-487b-9669-ef4e802647bf.png

But when I try to SSH:

9393fd6d-e874-40a1-a6d8-8f69b69b1016.png

So I can't continue the process of trying to install the display drivers on this page: https://www.mod-bros.com/en/faq/mobro/raspberry/display-drivers

(I was hoping once I did that, the 7" official screen would work, but I chose that option in the setup wizard so I would have assumed it would already have the drivers for it..)

Since the screen also doesn't work with Raspbian, unless I'm forgetting that you have to add something to the config file, it's probably the screen or the connection right?

Screen is brand new from amazon, arrived today. I have several DSI cables and have tried them all, I have tried powering the screen using the GPIO cables as well as with another USB cable and I can't even get the backlight to come on, let alone the rainbow startup image. I had the same screen a few years ago and got that working no problem, bought another one so I could have a sysinfo screen inside my PC:

https://i.imgur.com/KzQRSnW.jpg

About here, with the RPi behind it near the PSU.

 

I appreciate you trying to help thank you.

Well, I've tried every ‘solution’ I can find online, I think the screen may just be dead on arrival, I've re-seated the cables numerous times etc not once have I even had the backlight come on. Going to send it back for a replacement. 

Okay I got a new screen today. Still not getting output to it from either modbros or raspian. The pi's DSI connector must be faulty or something. Don't suppose anyone knows how to check that?

What are the requirements for the 7" official screen to show the backlight and / or the rainbow splash screen? I am trying to narrow down and diagnose the problem. Thanks.

After setting set_root_configurable and restarting, I'm still unable to connect again via ssh. It's visible on the network, same IP etc.

Edit: It's actually NOT on the network. After the reboot it's no longer on the wifi, and the modbro wifi isn't an available connection.

Okay, it turns out the DSI connector on the RPi itself is bad. I have to push the ribbon cable towards as well as down, turn the unit on, and then it's fine - if I power off though I need to make the initial connection again like this. I can probably put some spare cable in as a shim or something.

 

Login to comment

Login now
Like most websites, we also use cookies. But don't worry, we only use them for your login and statistics.