Old version download

5 people are following

Is there a place to download the old versions of the Windows App? I have a customized theme that does not work on the new version. 

Replies 1 - 10 (10)

What is missing in the new version to make the dashboard the same as you had in the old version? 

I second the initial question: Is there a place to download the old version? The old version worked fine with a raspberry pi as the monitor. I still have a second computer that works under the old config, but I can't figure out how to transfer those settings to my main computer. The new install just shows a white screen on the PI, so I guess it doesn't find a valid dashboard setup. I don't want to go thru the pain and setting everything manually. If I remember correct, the old dashboard was a free add-on that just works for me.  The old setup page shows only blurred out screenshots, so it's impossible for me to follow. 

Thanks for pointing out the issue regarding the images on the Raspberry Pi setup guide. We will fix that.

The Raspberry Pi setup hasn't changed and does work the same on the new version as it did for the old version.
Just flash our image, connect to the hotspot created by the Pi and follow the configuration wizard.

Once your Pi has connected to your PC, it will show up as a dashboard in MoBro. Initially this will be empty.
You can open the dashboard builder by clicking on the ‘configure’ button.


Then you can freely create your dashboard by simply adding widgets and selecting the metrics you would like to be displayed.
The new editor is a lot easier and more customizable compared to the old version, so you should be able to recreate any theme you had in the old version. There is also a free dedicated "dubbadhar" widget pack you can install from the marketplace that includes all the widgets from old theme.

You can also check out our Discord where some others have shared their dashboard configurations that you could import directly.

Thank You! 

I've managed the PI to connect to the updated Windows app, showing a white blank screen.

When starting the PI  a pop up message alerts of the PI connecting with the option to configure a Dashboard.

I configured that Dashboard, but it is not displayed on the PI. I think it's related to the screen resolution of the PI 800 x 400, dashboard shows the resolution at 0 x 0.



 How do I change the Resolution?

I don't see that option in the edit screen.

@MoodyDirk while the PI is booting and connecting to MoBro is it showing any images like searching for MoBro… or anything like that? just want to make sure the display driver is working correctly. 

There is no option to change the resolution, as the PI basically reports its resolution to MoBro after connecting successfully and rendering the dashboard.

Are you using the latest version of the PI image or an older one? If its a rather old image it might have a quite outdated chromium version. 

Yes, the PI screen, after connecting to WiFi, shows a screen like ‘… looking for Modbro apliccations on the network …', after a couple of seconds shows a green checkmark, then screen goes black and finally white (when ‘normally’ the dashboard is shown.

This still the original PI image V11.1 …



Could you try using the most recent v12.3 image? You can download it at the bottom at

The version of the browser installed on the old 11.x image is pretty old by now. I'm not 100% sure, but it could be that it doesn't support some features that are required for the new dashboards to work

Yes, this worked.


The configured dashboard is now displayed on the Raspberry Pi.

Thank You!

이전 버전을 다운로드하려면 어떻게 해야 합니까? 직접 만드는 것은 너무 고통 스럽습니다.

Ma solo a me non funziona? L'applicazione non mi fa installare mobro service. ho provato tante volte a cancellare il programma e re installarlo. ma niente.


Login to comment

Like most websites, we also use cookies. But don't worry, we only use them for your login and statistics.