DISCUSSION

Pi not being able to find PC that has the desktop app

3 people are following

Hello, can have some ideas on how to fix the issue of thee pi not being able to find the PC that has the desktop app. The pi is reachable through a browser by typing its ip on the local network and it loads the configuration page. The pi loads 100% but get stuck on “Searching your network for the MoBro PC application”. I have check the firewall and all seems right. Using windows 10. Both the PC and pi are shown being on the network on my router. Any solutions?

 

Thanks!

Replies 1 - 4 (4)

Hi @MatthewM 

This problem has been brought up by several people by now, but we have not yet been able to determine the cause.

Could you try to completely disable the firewall on windows for a few minutes and give it try this way? Just so we can definitely know if it's a firewall issue or not.

But please don't forget to turn on your firewall again after testing!

Also did you try to configure your Raspberry Pi to use static Ip address instead of the default discovery? If yes, does that work or do you run into the same issue?

Hello @Seraksab 

I did disable the firewall and gave it a try however that did not fix the issue. Yes I tried both for the ip assigned and manually. 

What I did do is unplug the pi, connect via ethernet, powered the pi back on and it found the PC and worked properly. So I powered the pi back down, unplugged the ethernet and powered back on connecting via wifi and it found the pc and is working now. I do not know exactly how that processes made it work but it is working now!

Hope that info helps!

Have you tried to sudo apt update & sudo apt full-upgrade your raspberry pi?

Thanks for testing @MatthewM 

At least we now know that the issue isn't the firewall or our firewall rules. That's a start :)

I'm glad that it's now working for you. Although given the steps you mentioned I honestly have no clue how that solved the issue 😅

@Racoon yeah updating is also always a good try in such cases :) Just be aware that in some rare situations this may interfere with the MoBro service. As we of course can only test with the Raspian and library versions that we ship the image with and not updated ones that are released later. Normally that's no issue though.

Login to comment

Login now
Like most websites, we also use cookies. But don't worry, we only use them for your login and statistics.