QUESTION

USB Network shows as COM with RPi Zero 1.3

2 people are following

I recently flashed version 12.3 to a micro SD card to use with a Raspberry Pi Zero 1.3. I used a WiFi dongle with an OTG adapter to connect to the configuration hotspot. I set the network type to USB and completed the configuration.

After updating/rebooting, Windows 10 recognized there was a RNDIS device and started to install drivers. When it finished and said the device was set up successfully, though, it was installed/identified as a USB Serial Device (COM). So it appears to have installed, but it is not showing as a network adapter.

Rebooting the Pi with only USB to PC (and HDMI to monitor), MoBro says that it successfully connected to the network, and starts trying to find the desktop app. But, it still doesn't show in Windows as a network device, so I cannot complete the PC side configuration.

What am I missing here? Is there a different way to install the device/drivers and/or to identify what type of device it is?

Thanks in advance for any help!

Replies 1 - 1 (1)

Hi @drummerdick 

That sounds like a similar problem like the one over here

Perhaps manually installing that RNDIS driver would also solve your issue
You can download it here. According to the post I linked above, it's taken from this forum here

I do NOT know whether that is an official or even the correct driver though, as I have not tried it myself!

Login to comment

Login now
Like most websites, we also use cookies. But don't worry, we only use them for your login and statistics.